Перейти к содержимому
  • 0
PetyaBorisov

Не могу скачать MineOS

Вопрос

У меня проблема с установкой при каждом запуске кодау меня появляется ошибка

/home # wget -f https://raw.githubusercontent.com/IgorTimofeev/MineOS/master/Installer/BIOS.lua /tmp/bios.lua && flash -q /tmp/bios.lua && reboot

Downloading... failed.

HTTP request failed: /bin/wget.lua:72: sun.security.ValidatorException: PKTX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Рекомендуемые сообщения

@ECS Java автоматически скачивается лаунчером а OpenComputers 1.8.3 при вводе твоего кода пастебин жалуется что сайт гитхаб заблокирован провайдером или конфигурацием но если я могу зайти то это в конфиге нужно делать

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ошибка PKIX происходит  из-за устаревших сертификатов в хранилище Java. Либо обновляй её, либо сертификаты. Вручную или автоматически - это уже не суть важно. А пастбин жалуется как раз из-за неё

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@ECS И как установить сертификат в Java?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня есть Java 8 ещё и Java(TM) SE Development Kit 17.0.11

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тем более 1.12.2 поддерживает 8 версию джавы

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 12.06.2024 в 15:13, PetyaBorisov сказал:

Тем более 1.12.2 поддерживает 8 версию джавы

Не надо путать два разных понятия: версию языка и версию JRE.

 

Да, игра работает на Java 8, но это только язык. У самой JRE ещё есть приписка — вроде 8u42. Здесь 42 — номер обновления. Думаю, очевидно же, что если в JRE баг, то фикс его язык никак не меняет? Проблема ведь не в языке, а в его реализации.

 

Поэтому, хоть Java всё так же восьмая, реализация её получала множество обновлений различного характера. В частности, почти 8 лет назад один из таких апдейтов, 8u91, добавил в список дефолтных сертификатов те, которые нужны на замену протухавшим старым, и именно их использует GitHub.

 

В 10.06.2024 в 17:35, PetyaBorisov сказал:

@ECS Java автоматически скачивается лаунчером а OpenComputers 1.8.3

Возникает вопрос: какого чёрта качается JRE лишь немногим новее, чем MC 1.7.10, чтобы запускать MC 1.12.2?

 

Решение этого вопроса — уж точно не область ответственности ни меня, ни @ECS, которого ты нещадно пингуешь. Скачай последний апдейт восьмой JRE (это, на секундочку, 8u411 — более, чем на 320 апдейтов новее, чем у тебя) и заставь лончер юзать её.

 

P. S. Это форум, а не мессенджер какой-то. Здесь есть кнопка «Изменить». Не надо постить миллиард сообщений по одному предложению в каждом.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Присоединяйтесь к обсуждению

Вы можете написать сейчас и зарегистрироваться позже. Если у вас есть аккаунт, авторизуйтесь, чтобы опубликовать от имени своего аккаунта.

Гость
Ответить на вопрос...

×   Вы вставили отформатированное содержимое.   Удалить форматирование

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.


×
×
  • Создать...